Add file to vault does nothing
6 months ago

I'm having trouble finding what permission I'm missing for a particular group in PDM.  When a user in this group drags files into the vault, they show as grayed out local files, and nothing happens when you right click> 'Add to File Vault'.  There's no error message, and the file stays gray.  I've checked the folder and state permissions, and the Adding Files settings (that the file type is listed as one that should be added).  There's nothing in the log indicating an error or even an information entry about what's happening.  Any ideas?


Categories: Data Management, SOLIDWORKS PDM∕Enterprise PDM

Last comment By: Elisabeth Daley   Wed, 16 May 2018 21:47:50 GMT
Re: Add file to vault does nothing


1 To check whether the user / group has rights on the archiving server.

2. At group or the user can it will be dropped settings on a tab of adding of files and menu - they need to be recovered.

3. Also there can be firewall or failure of the SQL server.

By: Sam Sam  Tue, 15 May 2018 21:40:37 GMT
Re: Add file to vault does nothing

Hi Sam, thanks for your reply.  I'm not sure what you mean by item 2.  I don't think it's a firewall/archive server rights issue, because actually the user group is able to add files to some folders.  Its just in another section that I want to be more restricted that I'm having the problem.  Instead of having a smaller subset of people able to add files there, no one can add them at all.

By: Elisabeth Daley  Tue, 15 May 2018 22:20:21 GMT
Re: Add file to vault does nothing


I think that you tried to reboot the server and to come under other group too, therefore I specify that wanted to tell on point 2: - in settings of the user and/or group (and also all users) there is point of settings of the Menu, sometimes there are problems - it is possible to try to reset the menu or to copy from other user.


And Show working versions of files - does not need to be included?

And the local cache - has some settings?

Problem in old folders or only in new?

Dispatch - is some settings?

Addins versions - correspond to the version of PDM?

By: Sam Sam  Wed, 16 May 2018 05:33:52 GMT
Re: Add file to vault does nothing


Check "Show working versions of files" in folder rights. A new file will not have a Revision and is a working version.

By: Martin Solem  Wed, 16 May 2018 06:18:49 GMT
Re: Add file to vault does nothing

Did you check the user/group settings for adding files?

By: Arie Van Gelderen  Wed, 16 May 2018 09:29:15 GMT
Re: Add file to vault does nothing

Probably silence means absence of the decision.

In that case, there are some questions.

1. Whether there are users who consist in several groups? The problem can be here. In that case there is a sense to try to include "Permit or deny group-level access to files".

The group can try to give temporarily all permissions - something will change?

2. If any templates are used - it can is necessary to add permission for group?

3. Also As far as I understand, in Workflow there is an automatic transition - whether there are no problems there? In conditions or in something another?

4. Such problems with any type of files or c some extensions?

5. Problems only in case of drag and drop? If to copy and insert - the same result?

By: Sam Sam  Wed, 16 May 2018 20:21:57 GMT
Re: Add file to vault does nothing

That did it!  Thank you very much!

By: Elisabeth Daley  Wed, 16 May 2018 21:47:36 GMT
Re: Add file to vault does nothing

I did, but thanks!

By: Elisabeth Daley  Wed, 16 May 2018 21:47:50 GMT
You are not authorized to view this page No results found! Suggestions: Check spelling, try a different search, or browse topics below.