Mouse Gestures in SW2018 Question
SOLIDWORKS Forums
1 month ago

I just started using SW2018 last Friday, and it seems to me that after right-clicking I have to drag the mouse farther to activate the Mouse Gestures than I did previously.  Is anyone else seeing this, or have I finally slipped over the edge?


Categories: User Interface

Comments
Last comment By: Ben Langdon   Wed, 09 May 2018 23:55:08 GMT
Re: Mouse Gestures in SW2018 Question

Hey Glenn,

 

I did notice a difference in the appearance of the mouse gesture tool in SOLIDWORKS 2018, but the behavior is identical to 2016 and 2017. In 2018, the tool looks larger due to lack of shading, which might have the effect of being slower to use?

 

Check it out the images from 2016, 2017 with 2018 on the bottom...

 

compare.JPG

 

Thanks!

Ben

By: Benjamin Modic  Tue, 06 Feb 2018 20:30:24 GMT
Re: Mouse Gestures in SW2018 Question

Just been using these and definitely noticeably slower,

had 2015 next to 2018,

 

twice the mouse travel to get 2018 gestures

By: Ned Hutchinson  Tue, 06 Feb 2018 20:37:03 GMT
Re: Mouse Gestures in SW2018 Question

Ned Hutchinson wrote:

 

Just been using these and definitely noticeably slower,

had 2015 next to 2018,

 

twice the mouse travel to get 2018 gestures

Hi Glenn and Ned,

 

The mouse gestures should execute as soon as your mouse hits the inner edge of the "ring". This is true if you move your mouse slowly so you can see the mouse touch the ring, or even if you move your mouse quickly so the ring never shows on the screen. And as Ben showed, the ring sizes are the same. So a couple of questions for you:

  1. If you move your mouse slowly, is the command not executing when you hit the inner edge of the ring?
  2. Is the ring showing the same size as it was in the previous version you were using?

If these two are true, then it should be the same distance to execute the command in the two versions if you are moving your mouse slowly (and this should be very easy to verify). Then if you move your mouse quickly, you should also see the command executing with the same distance, even though the ring is not showing. Is this not happening?

 

Thanks,

Jim

By: Jim Wilkinson  Tue, 06 Feb 2018 20:56:31 GMT
Re: Mouse Gestures in SW2018 Question

it has to be something in the mouse settings....I am to old school cause I still don't use those....enjoy...

By: David Matula  Tue, 06 Feb 2018 21:29:31 GMT
Re: Mouse Gestures in SW2018 Question

Jim,

 

Thank you for replying.  For your question 1, when I move my mouse slowly it does appear that the ring shows up when I've traveled approximately the distance from the center of the wheel to the inner edge, but since the wheel then appears with my cursor in its center it's difficult to say for sure.

For question 2, I got a new computer last Friday, with SW2018 installed on it, so I don't have access to SW2017 to compare, but I'm sure that I have to move my cursor further to wake up the Mouse Gestures than previously.  I noticed that Friday on my new desktop, and I'm at my VAR this week for a class and seeing the same thing on their laptop.  I use Mouse Gestures so often that I noticed the difference right away.

 

If you'd like I can install SW2017 on my work machine when I get back on Friday (or next week, depending on how far behind I'll be when I get back).  To add to the variables, my new computer and the ones here at the VAR are using Win10, and my previous one was still Win7, but I don't know if that matters.

By: Glenn Schroeder  Tue, 06 Feb 2018 21:30:33 GMT
Re: Mouse Gestures in SW2018 Question

Is it possible your mouse acceleration settings are different between the two machines? That might make a difference when swiping quickly.

By: Jeremy Zuvich  Tue, 06 Feb 2018 21:33:34 GMT
Re: Mouse Gestures in SW2018 Question

Jeremy Zuvich wrote:

 

Is it possible your mouse acceleration settings are different between the two machines? That might make a difference when swiping quickly.

 

Thank you for replying, but I wouldn't think so, since I usually move my mouse slowly to wake up the ring, and then choose the desired operation.  I'm certain it's the distance I have to travel instead of the speed.  However, that's something I can certainly check on when I get back to work.

By: Glenn Schroeder  Tue, 06 Feb 2018 21:38:04 GMT
Re: Mouse Gestures in SW2018 Question

Comparison using top right corner of screen, starting just below the feature manager and active screen dragging downwards

mouse geasture start.png

2015 sketch                                                                2018 sketch

mouse geasture 2015 sketch.pngmouse geasture 2018 sketch.png

See how much further it moves before activation

 

2015 part                                                                    2018 part

mouse geasture 2015 part.pngmouse geasture 2018 part.png

 

2015 assem                                                              2018 assem

mouse geasture 2015 assem.pngmouse geasture 2018 assem.png

By: Ned Hutchinson  Tue, 06 Feb 2018 21:50:41 GMT
Re: Mouse Gestures in SW2018 Question

Ned Hutchinson wrote:

 

Comparison using top right corner of screen, starting just below the feature manager and active screen dragging downwards

mouse geasture start.png

2015 sketch 2018 sketch

mouse geasture 2015 sketch.pngmouse geasture 2018 sketch.png

See how much further it moves before activation

 

2015 part 2018 part

mouse geasture 2015 part.pngmouse geasture 2018 part.png

 

2015 assem 2018 assem

mouse geasture 2015 assem.pngmouse geasture 2018 assem.png

This is definitely not expected behavior in 2018. Your image in 2015 is as expected. When you start dragging with the right mouse button, the gesture ring should not appear until you move your mouse a certain distance and then when it does appear, it should appear with its center point at the location you started dragging as per your 2015 images). Your 2018 images appear to show the exact behavior that Glenn described with the ring not appearing when you move a short distance, but rather when your mouse gets to the point where the edge of the inner ring should be; and then it appears centered on the current mouse position (not where you started the drag).

 

I am not getting this behavior in 2018, so the question is what is different on your machines that is causing it. Perhaps it is something about how your UI is setup, so maybe if you could show a full screenshot, I could figure out why. I tried putting the configuration toolbar in the location your 2015 images show, but that didn't change anything. I can't tell whether your task pane is pinned or not (it is open in the top image);  I tried it with it pinned, unpinned and open, and unpinned and closed and the behavior was still the same for me as your 2015 images.

 

So the next step I think is for one or both of you to post a full screenshot and I can see if I can figure it our from there.

 

Thanks,

Jim

By: Jim Wilkinson  Tue, 06 Feb 2018 23:37:13 GMT
Re: Mouse Gestures in SW2018 Question

Here we go

Fresh setting .ie stock install

ui.png

the gestures work normal until you go to sketch mode.

mouse geasture start.png

new part, first gesture without doing anything else

mouse geasture 2018 part 1st thing.png

Click sketch tab, plane then mouse gesture

mouse geasture 2018 part sketch then gesture.png

exit sketch back in part mode

 

mouse geasture 2018 part 2nd thing.png

By: Ned Hutchinson  Wed, 07 Feb 2018 00:41:18 GMT
Re: Mouse Gestures in SW2018 Question

While I have not noticed the issue with mouse gestures yet.  I have noticed that SP1.0 seems much slower than SP0.1 and definitely slower than SW2016 SP5.0.  But that too seems system dependent as others in the forum have stated they see no response issues.

By: Solid Air  Wed, 07 Feb 2018 00:43:36 GMT
Re: Mouse Gestures in SW2018 Question

Here's what it looks like on the laptop here at the VAR where I'm taking a class.  I can post a screenshot of my new computer at work when I get back on Friday if you haven't figured it out by then.  I didn't use the Copy Setting Wizard when setting it up, but I might try it to see if that will have any effect.

 

By: Glenn Schroeder  Wed, 07 Feb 2018 14:26:25 GMT
Re: Mouse Gestures in SW2018 Question

Ned Hutchinson wrote:

 

Here we go

Fresh setting .ie stock install

ui.png

the gestures work normal until you go to sketch mode.

mouse geasture start.png

new part, first gesture without doing anything else

mouse geasture 2018 part 1st thing.png

Click sketch tab, plane then mouse gesture

mouse geasture 2018 part sketch then gesture.png

exit sketch back in part mode

 

mouse geasture 2018 part 2nd thing.png

Hi Ned,


I'm not able to reproduce it even with this additional information, so at this point, I would suggest recording a problem capture of the behavior with SOLIDWORKS Rx and send it to your reseller for further troubleshooting.

 

 

Thanks,

Jim

By: Jim Wilkinson  Wed, 07 Feb 2018 15:27:22 GMT
Re: Mouse Gestures in SW2018 Question

Hello Jim,

 

I'm sorry I didn't get back to you on this sooner, and thank you for looking into it when I first posted this Discussion, but I wanted to let you know that an hour or so ago I shut SW down thinking I was going to download and install sp2 (didn't work, apparently I can no longer be trusted with administrative access; and to think I used to like our IT people).  I just now opened it back up and Mouse Gestures is working like it used to.

 

Now that I think about it, I ran across a post at Is there any setting for the precision of selecting two lines to dimension? that recommended de-selecting the option shown below, so I did that earlier this morning.  I wonder if that's what fixed it?

 

Ned Hutchinson, you might try that if you're still getting the behavior you described above.

 

 

Glenn

By: Glenn Schroeder  Thu, 08 Mar 2018 19:16:54 GMT
Re: Mouse Gestures in SW2018 Question

Tried switching setting still the same both checked/non checked.

 

Mouse feels much nicer with enhance pointer precision on. Jumpy with off.

 

Then i thought mabye my mouse cause it has three dpi speeds ie. slow,med,fast mouse movements.

Tried all three settings all same

Tried another mouse from other side of office, still same behaviour

Tried different templates but that did nothing either

 

I will try to record rx of behaviour

By: Ned Hutchinson  Thu, 08 Mar 2018 21:44:20 GMT
Re: Mouse Gestures in SW2018 Question

Recorded RX of mouse behavior and sent to VAR.

Got this Back.Today got SPR no. back

Hi Ned,

Just to keep you up to date SWX agree this appears to be a regression from 2017, possibly only affecting Windows 10

They are trying to pinpoint the exact reason / specifics of the issue and I will keep you updated.

 

Today got SPR no. back

Solidworks have confirmed this is a regression / fault and have raised an SPR

SPR 1072102 - It takes a longer drag to evoke the mouse gestures once it is called out in the sketch mode on Windows 10 systems.

By: Ned Hutchinson  Tue, 13 Mar 2018 22:04:01 GMT
Re: Mouse Gestures in SW2018 Question

Ned Hutchinson wrote:

 

Solidworks have confirmed this is a regression / fault and have raised an SPR

SPR 1072102 - It takes a longer drag to evoke the mouse gestures once it is called out in the sketch mode on Windows 10 systems.

Hi Ned,

 

We're trying to figure out exactly how to reproduce this since it is reproducible on some machines and not others. Can you do me a favor and save out all of your settings using Copy Settings Wizard and then attach it here so we can take a look?

 

Thanks,
Jim

By: Jim Wilkinson  Wed, 14 Mar 2018 13:37:33 GMT
Re: Mouse Gestures in SW2018 Question

Here it is Jim

 

thanks for your help

By: Ned Hutchinson  Wed, 14 Mar 2018 21:55:50 GMT
Re: Mouse Gestures in SW2018 Question

Got this today, implemented in sp3,

 

 

GOOD JOB SOLIDWORKS

 

 

Dear Ned,

 

The following SPR (SolidWorks Performance Report) status has changed to Implemented.

 

SR# (Service Request): 1-17100005351

SPR#: 1072102

Description: It takes a longer drag to evoke the mouse gestures once it is called out in the sketch mode on Windows 10 systems

Status: Implemented.

Version: 2018 SP03

 

 

For more information, visit the SolidWorks Customer Portal and select My SPRs.

 

DS SolidWorks does not guarantee that this SPR fix will be available in the indicated future release of the product since at this time the SPR fix has not completed QA procedures that incorporate all SPR fixes and enhancements into a new version of our product.

 

Best Regards,

 

Dassault Systèmes SolidWorks Corp. Technical Support

By: Ned Hutchinson  Fri, 27 Apr 2018 01:55:39 GMT
Re: Mouse Gestures in SW2018 Question

nice to see this fixed so fast. had 2018 installed a couple weeks ago and found this problem but never thought to look about it. gota ask it to update to sp3 now

By: Ben Langdon  Wed, 09 May 2018 23:55:08 GMT
You are not authorized to view this page No results found! Suggestions: Check spelling, try a different search, or browse topics below.