I for a long time had DraftSight free version installed on a laptop.
I have lost the use of the laptop and wanted to install DS on my desktop Windows 8.1 Pro system.

I accepted the version offered on the web page which was 2018 SP0 Windows 32bit which matches my OS.

Download was fine. 
On install I receive the same installer error (1722) each time. I tried to run directly from Download directory, no joy, closed all other applications, no joy, tried with administrator privileges, no joy and then moved file to documents folder and ran installer with administrator privileges and still no joy.
Each time the install seems to proceed fine with unpacking, licence selection (free) and acceptance and then the progress bars work through to what seems to be the end (UPDATE: I moved the error dialog out of the way and saw the last progres bar was only at about 15%, others had run to completion) and then an error window pops up on the installer.  Click OK and it rolls back everything as before.  I have found one other used on a French blog that mentioned a similar error with no solution but very little else relating to my problem.


It mentions register_FXVistaPreviewDll at some uncertain location (the popup error has inadequate information even for a psychic person) and that's it.


This is not a Licence registration problem as the program has yet to complete the installation process but somehow related to DLL registration in the registry I surmise.


Is there a way to manually guide the installation process?

Can I find the missing file and save it in the expected place and "register" it in advance so the installer will be happy?

Is there an obvious reason why this might be happening?

I can locate the .CAB file during the install process and make a copy and extract the problem DLL. I placed an advance copy in %PROGRAMFILES%\Dassault Systemes\DraftSight\bin\ all lowercase and also in the camel case as it generates during the install.  No difference and it deletes it with the other files on exit.  I tried to register it as a DLL using the command "%windir%\System32\regsvr32.exe /i FxVistaPreview.dll" when in the \bin directory running CMD as administrator.  It gave an error about the file not being suitable as a DLL or something but not sure if I was doing something else wrong.


Can a corrupt CAB file be hiding inside the instalation EXE?  I would hope not but downloading it again may not provide extra information.



DraftSight 2018 SP0 error.jpg


Message was edited by: Kalle Mikael

Categories: Administration

Last comment By: Brad Huitt   Wed, 20 Jun 2018 04:12:13 GMT
Re: Installation error 1722 on DraftSight 2018 SP0


It turns out you need to install Visual C++ 2015 (I installed both x86 and x64 versions) and everything will be fine.

By: Noneof Yourbussines  Wed, 22 Nov 2017 09:25:38 GMT
Re: Installation error 1722 on DraftSight 2018 SP0

This isn't whole answer. We are discussion "Installation error 1722" over at DraftSight 2018 fails Automated Package Tests · Issue #8 · teknowledgist/Chocolatey-packages · GitHub https://github.com/teknowledgist/Chocolatey-packages/issues/8#issuecomment-353352487


On fully patched Windows 10 installation I do not need to install the Visual C++ 2015 stuff (same for a fully patched Windows Server 2012 R2 and fully patched Windows Server 2016).


I used Dependency Walker and this told me VCRUNTIME140.DLL was missing.



Looks like VCRUNTIME140.DLL is provided by Microsoft Visual C++ Redistributable for Visual Studio 2017


But installing onto a fully patched Windows Server 2012 R2 the VCRUNTIME140.DLL dependencies are met by the UCRTBASE.DLL




Fully patched Windows10, draftsight 2018 installs, but Dependency Walker shows


Not sure if the VCRUNTIME is the problem now.

Anyone help on -what- other packages need to be installed or patches/KB's need to be applied for 2018 to be installed?


By: Bob Tanner  Thu, 28 Dec 2017 06:57:14 GMT
Re: Installation error 1722 on DraftSight 2018 SP0

Noneof Yourbissines' solution was the solution for me, but I had both of the VS 2015 C++ redistributables installed already.  Repairing them didn't work either.  After re-evaluating the error message (like Kalle Mikael the error message said it was unable to register a DLL using regsvr32) I deduced that maybe there was a problem with the x86 (32bit) version of the VS 2015 C++ redistributables.  So I

  1. downloaded the VS 2015 C++ Redistributable package from Microsoft download
  2. then I uninstalled the x86 version
  3. rebooted
  4. then re-installed it.

After that I was able to install Draftsight 2018 SP2 without any problems, as well as some other software that was giving me fits!

By: Brad Huitt  Wed, 20 Jun 2018 04:12:13 GMT
You are not authorized to view this page No results found! Suggestions: Check spelling, try a different search, or browse topics below.