Solidworks 2017 Thread Error
9 months ago

I keep attempting to create threads in Solidworks 2017 and have tried to do so on various features. However, every time I select an edge of a cylinder, I get the message "input data to create thread is invalid" and am unable to create the thread. I've tried this on various objects yet all yield the same result. Any help would be appreciated.

Categories: Modeling and Assemblies, Parts and Features

Last comment By: Coby Turman   Fri, 15 Sep 2017 13:29:18 GMT
Re: Solidworks 2017 Thread Error

Check your thread options (size, etc.) before selecting the edge if that helps SolidWorks 2016 New Thread Features

By: Deepak Gupta  Thu, 14 Sep 2017 04:50:02 GMT
Re: Solidworks 2017 Thread Error

Coby, post a screenshot with the error showing and we can offer better advice.

By: Rick Becker  Thu, 14 Sep 2017 11:45:28 GMT
Re: Solidworks 2017 Thread Error



This may be as simple as choosing the right option. I had a new guy who was doing this for personal practice and he kept picking the wrong format.


If threading a hole make sure tap is selected, if it is a rod make sure die is chosen for the form of the threads.


Also if the diameter is right on use the cut option.


Good luck.

By: Paul Risley  Thu, 14 Sep 2017 11:57:09 GMT
Re: Solidworks 2017 Thread Error



I'm almost completely certain I'm making some sort of error like that. I've been trying to teach myself various features throughout Solidworks, Thread being among them. To further define my problem, I'm trying to create an internal thread inside of a hex nut. I'm sure I'm making some rookie error. I've attached the dimensions and the error message that I get when I select the circular edge. All units are inches








By: Coby Turman  Thu, 14 Sep 2017 18:30:49 GMT
Re: Solidworks 2017 Thread Error

Seems like thread profiles are missing or their path is not set.


There should be threads spec mentioned here (like picture on right).



Check and set their location



In case you can not find them, download from this post by Daljeet :, place them in desired location and map the path under file locations > Thread profiles

By: Deepak Gupta  Fri, 15 Sep 2017 05:55:34 GMT
Re: Solidworks 2017 Thread Error



That solved it! It looks like when I uninstalled SW16 and installed SW17 some of the file locations remained sourced at SW16. Thanks for your help.



By: Coby Turman  Fri, 15 Sep 2017 13:29:18 GMT
You are not authorized to view this page No results found! Suggestions: Check spelling, try a different search, or browse topics below.