Discover what SOLIDWORKS users are discussing.
I am using Solidworks 2018 with EPDM. When I file save as in an assembly, it then proceeds to give me a save as dialog prompt to save all the parts and assemblies in my original assembly one by one. I had this problem in 2015 and solved it by checking the box "Don't prompt to save read-only referenced documents (discard changes)" This check box is still checked. I also tried to change my registry to put a "1" in the "Abort read-only Top Docks" value.
SOLIDWORKS Forums
13 hours ago
Smart component help I’m delving into somewhat unknown territory here so bear with me and apologies if some of my questions are considered basic.
SOLIDWORKS Forums
13 hours ago
This problem isn't obvious to be figure out. Let me describe: When I make a sketch of a new part (here namedPART A) with external reference of an assembly (namedASM B& it's rigid), there is no warning popping up.
SOLIDWORKS Forums
1 day ago
Utilizing Multibody parts I'm in the habit of creating certain parts as a single multi-body part rather than using assemblies. It ends up making things a lot easier.
SOLIDWORKS Forums
1 day ago
I am using 2018 Standard, SP4. I have an assembly and I delete all the attachments to a part and pull it out, and then turn it around and reinsert the part back into the assembly. The part did't have any attachments when I pull it out so it should be free to rotate. I pulled the part out of the assembly, but when I click on the part and try to rotate it so it can be assembled correctly, the whole assembly rotates with the part preventing me from reinstalling the part.
SOLIDWORKS Forums
1 day ago
I have an assembly with a few parts. I want to use some of the geometry from one of the parts as reference (create planes etc.) and create new geometry in another part. When I try to do that I get a message saying “the component being edited is locked. You can edit the component but can’t create an external reference
SOLIDWORKS Forums
4 days ago
This is totally weird behavior and happened once a while The part is visible but I can't select a face or edge etc - Seems like it's invisible
SOLIDWORKS Forums
5 days ago
Since upgrading to SolidWorks 2015, I've had two co-workers have an issue where some lights in their assembly are turned off without their input (at least that we know of). The lighting setup in our assembly template includes 1 ambient light and 2 directional lights, all turned on. When this issue occurs, the ambient light remains on but the two directional lights are turned off.
SOLIDWORKS Forums
5 days ago
For as long as I can remember, SW would occasionally behave badly when rotating models with the standard middle-click drag operation. The entire model would disappear completely, as though the rotation center was way off in space somewhere. Currently, I'm using SW2016 SP2, and it happened a few times today on one particular assembly model, so I decided to investigate.
SOLIDWORKS Forums
5 days ago
Is it possible to create a Customised Toolbar which would give the user access to the Standard Planes (Front, Top & Right), the planes which are located at the top of the Feature Manager? In an assembly, let say I need to assign a parallel mate between the Top plane of a part and the Top plane of the assembly.
SOLIDWORKS Forums
6 days ago
Say a electrical box connector added to a box and have the box connector cut the hole? Yes, smart components is the answer you need
SOLIDWORKS Forums
6 days ago
Its probably a setting right in front of me but I cannot find it. When I delete a components in an assembly the mates are remaining, just grayed out. Where can I find the setting so when I delete components it will delete their mates?
SOLIDWORKS Forums
7 days ago
I am new to Solidworks 2018. I built an assembly, but during the process I seemed to have done something that has eliminated my Mates folder for the part that I was working on. I don't have any idea what I did and I can't get it back. Any ideas how to recover that folder?
SOLIDWORKS Forums
9 days ago
SolidWorks 2012 SP1.0 A coworker is having trouble getting parts tostayhidden/unhidden in his configurations. He has three parts in the default config, but when he changes to a new config, hides 2 of the parts, then switches back to default, the 2 parts stay hidden.
SOLIDWORKS Forums
11 days ago
Working newton's cradle question? I'm trying to make a working newton's cradle using hooks to suspend the balls along the frame. This creates problems I hadn't anticipated with regards to making the object work.
SOLIDWORKS Forums
12 days ago
Just more of a check than anything. Is there a way in a subassemblies to mate individual parts to different parts in the main assembly.
SOLIDWORKS Forums
12 days ago
I noticed that solidworks defaults to fixed when inserting a new part into assembly and this really bugs me. Is it possible to change this so it won't fix. Normally I never use fixed and instead mate origin to origin in case it's a first part.
SOLIDWORKS Forums
12 days ago
I have a couple assembly files that have some sketch entities left after moving a part that I can't get rid of. They are template assemblies that we are using to layout the operations to machine parts. After it is all laid out we save it as .step to bring it into hyperMill to program. The entities don't transfer so it does not affect the usage it is just more of an annoyance of having bogus geometry that I can't get rid of.
SOLIDWORKS Forums
12 days ago
Intuitive Mate Replacement?? I was just thinking (as I was working) - it would be really nice if SW would make an 'intuitive mate replacement' command.
SOLIDWORKS Forums
12 days ago
I have been using solidworks for some years now, but am working ona project that is a little cumbersome in part qty's. I have inserted quite a few parts inthis assembly, and it seems every time I do so it wants to save the latest part, and it's subs. They have not been modified, just inserted into the assy model, I haven't even mated them.
SOLIDWORKS Forums
12 days ago
Hi, I have a part in an assembly. I always know whether it is fully / partially / over constrained with the 'f' or '-' or '+' in the name of the part in browser tree.
SOLIDWORKS Forums
12 days ago
I was using Creo before I moved to a new company with Solidworks. There are a few things that I can not figure out if there are setting that I can adjust or if it just is the way it is. I want to be able to turn of the "center spin".
SOLIDWORKS Forums
14 days ago
I was wondering if there is a quick way to have two types of appearance saved for an assembly? When we are working on a design, it is very usefull to have parts or weldments that get mated together in different colors. This makes a large assembly easier to work with.
SOLIDWORKS Forums
14 days ago
This is killin me. I have an assembly with two parts. I want to link a dimension in one part to another using equations. For some reason, every time I try to define a dimension as a particular global variable, Solidworks says that the dimension is "Read-only."
SOLIDWORKS Forums
15 days ago