Hello everyone,

I was having issues viewing part, assembly and drawing previews in Windows 7 File Explorer on "Details" mode. I sourced the forums and asked my reseller technical support, but no one could find an answer for me. I have Solidworks 2017 SP 4.1.

I have already tried these solutions:

1) Options --> General --> Show thumbnail graphics in Windows Explorer;

2) All solutions explained here: https://www.javelin-tech.com/blog/2016/03/solidworks-thumbnail-preview-missing/ EXCEPT for DLL registration.

I don't want to try DLL registration.

Any suggestions?

See attached file to see how thubnails look like now (Windows 7 File Explorer on "Details" mode).

Best regards.

 

Marco

 


Categories: General

Comments
Last comment By: Kyle Koehler   Thu, 08 Mar 2018 13:04:45 GMT
Re: Thumbnails don't show me part, assembly and drawing preview

Marco Lorenzin wrote:

 

I don't want to try DLL registration.

Is there any issue in not trying the DLL registration method? If you can not not do that then take a backup of your files and settings and do a complete uninstall followed by reinstall.

By: Deepak Gupta  Sat, 13 Jan 2018 08:21:40 GMT
Re: Thumbnails don't show me part, assembly and drawing preview

Hi Marco,


See if this thread helps since you are not even properly getting the part, assembly, and drawing icons:

How to display file icons

 

Thanks,

Jim

By: Jim Wilkinson  Sat, 13 Jan 2018 13:09:52 GMT
Re: Thumbnails don't show me part, assembly and drawing preview

Hi Jim,

I've already tried this solution, but it doesn't work.

Best regards

 

Marco

By: Marco Lorenzin  Mon, 15 Jan 2018 07:19:39 GMT
Re: Thumbnails don't show me part, assembly and drawing preview

Marco Lorenzin wrote:

 

Hello everyone,

I was having issues viewing part, assembly and drawing previews in Windows 7 File Explorer on "Details" mode. I sourced the forums and asked my reseller technical support, but no one could find an answer for me. I have Solidworks 2017 SP 4.1.

I have already tried these solutions:

1) Options --> General --> Show thumbnail graphics in Windows Explorer;

2) All solutions explained here: https://www.javelin-tech.com/blog/2016/03/solidworks-thumbnail-preview-missing/ EXCEPT for DLL registration.

I don't want to try DLL registration.

Any suggestions?

See attached file to see how thubnails look like now (Windows 7 File Explorer on "Details" mode).

Best regards.

 

Marco

 

Hi Marco,

 

I can't tell you why you're not getting the previews in Windows Explorer but I can tell you that it will work. See the pictures below for previews of .sldprt, .slddrw and .sldasm

 

prt prvw 2.png

 

prt prvw1.png

 

prt prvw 3.png

 

You can see I'm in detail mode in all three.

I know that this is very simplistic but I notice in your picture you seem to have the preview plane hidden.

If you look at my pictures, the icon to the right of the "Change your view" icon is pretty much all white. That icon in your picture shows a blue panel to the right. Hover over that and it should say "Show the preview panel". Click on that.

 

Hope this helps.

 

Edit:

I just noticed that you can't see that icon in any of my pictures.

Here is another that shows the icon.

 

prt prvw 4.png

By: Tony Tieuli  Mon, 15 Jan 2018 12:51:19 GMT
Re: Thumbnails don't show me part, assembly and drawing preview

Hi guys,

problem solved! Just deleted some Windows registry subkeys:

- subkey ".sldprt" on HKEY_CLASSES_ROOT

- subkey ".sldasm" on HKEY_CLASSES_ROOT

- subkey ".slddrw" on HKEY_CLASSES_ROOT

- subkey "SldPart.Document" on HKEY_CLASSES_ROOT

- subkey "SldAssem.Document" on HKEY_CLASSES_ROOT

- subkey "SldDraw.Document" on HKEY_CLASSES_ROOT

and:

- subkey ".sldprt" on HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/FileExts

- subkey ".sldasm" on HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/FileExts

- subkey ".slddrw" on HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/FileExts

 

Then I did a full SOLIDWORKS repair. Finally I run it as administrator and I restored file associations (Options/File Explorer).

Now I can see preview on part, assembly and drawing preview!

 

Best regards

 

Marco

By: Marco Lorenzin  Wed, 17 Jan 2018 19:38:57 GMT
Re: Thumbnails don't show me part, assembly and drawing preview

This answer works.  I have fought this problem for over 16 months now.  Finally a fix.

 

For those not comfortable with deleting registry files.  I suggest simply renaming them to ".sldasm_old" or something.

 

For the record did not have the "sldpart.document" files in the HKEY_CLASSES_ROOT folder.  But I did rename the files in .../FileExts and the ".sldasm" files in HKEY_CLASSES_ROOT as suggested by Marco.  By renaming it was easier to go back and fix if this screwed things up.

 

It did not.

 

After I renamed files... I went into Control Panel>Apps... selected Solidworks and clicked "Modify" and navigated my way to doing a Repair.  When that was complete... I opened Solidworks as "adminstrator" (not sure if that was necessary because when i open a folder with solidworks files in them the icons were fixed!!!)

 

Marco - Thank you for the answer that was very safe to use.

By: Kyle Koehler  Thu, 08 Mar 2018 13:04:45 GMT
You are not authorized to view this page No results found! Suggestions: Check spelling, try a different search, or browse topics below.