Discover what SOLIDWORKS users are discussing.
I come from an Alibre background and on that platform you can Ctrl drag and it drags a sub-assemblie out of a bigger assembly maintaining it orientation. The same command in solid works drags a part only.
SOLIDWORKS Forums
4 hours ago
I'm getting the "This part has features defined in the context of another assembly ..." I've done some searching on the forum and see that checking tools> options> system options> external references> allow multiple contexts will solve this but it is usually accompanied with a cautionary warning to only do that if you know what you're doing. I have no shame in admitting I have no idea what that is doing and so am wary of checking it.
SOLIDWORKS Forums
15 hours ago
While routing I sometimes come across this strange and irritating phenomenon. This usually happens when I save the pipe drawing as pdf and then I can't fix it. I usually have to redraw the pipe and this takes up quite a bit of time.
SOLIDWORKS Forums
1 day ago
Starting route alignment I am not very experienced in Solidworks Routing. I am struggling to create a pipe route from scratch, i.e. not building it directly onto the model I have.
SOLIDWORKS Forums
1 day ago
How to install toolbox in your design library. I try to open it but the toolbox need to be installed.
SOLIDWORKS Forums
1 day ago
Our company has standard installations that we are trying to turn into smart components or assemblies to make future assembly models easier. I am having consistent troubles with Solidworks 2016 crashing or temporarily freezing once multiple smart assemblies have been inserted. The lag and crashes increase as the number of smart parts or assemblies are added and inserted. Even drawings that call upon the assemblies with the smart components or assemblies struggle and crash.
SOLIDWORKS Forums
1 day ago
I have simple assembly with 9 part and 24 mates. It is a simple slide Take-up for a conveyor. It has a screw mate so that when you turn the nut on the threaded rod the pillow block bearing mounting plate will slide in the tubing. The problem starts when I bring 2 of these take-up slide assemblies into a top level assembly.
SOLIDWORKS Forums
1 day ago
I have two blocks that were originally converted from point cloud data and are now solid parts in SolidWorks. I am wanting to use the combine (subtract) feature in SolidWorks Part to remove the common geometry between both blocks. However, without a way to automatically align the two blocks the combine (subtract) feature does not accurately delete the common geometry. I have tried using mate to align the two objects, but because the point cloud data was converted to a mesh and then a solid part,
SOLIDWORKS Forums
1 day ago
Guys, I have to apologize in advance. I am an unwilling SW user, after being conditioned by 20years with PTC. I have intimate knoweledge of how Pro/E & Creo function. It has been a very difficult transition for me.
SOLIDWORKS Forums
2 days ago
How do I keep my scene settings when I go into and Isolate view inside an assembly? Blair Hollshwandner wrote:
SOLIDWORKS Forums
2 days ago
I've got a weird thing going on with new assemblies i make which drives me crazy. Every time i want to start a new assembly from a certain part (Part 8 for example in the picture attached) it's auto adding those 2 fixed unwanted parts
SOLIDWORKS Forums
2 days ago
I work with assembly's that have multiple pem nuts in them. Is their a way when I make configurations that I can suppress the pem nuts that are not mated to the part without picking them individually or group selecting them. You can do a box select on the screen or use the CTRL key and select them from the feature manager tree.
SOLIDWORKS Forums
2 days ago
I have been having issues with my model not showing correctly when opened from a parent assembly. It looks like the attachment and then you can see the part correctly when rotated (second screen shot). Then when opened again I get the screenshots with the prefix part1.
SOLIDWORKS Forums
2 days ago
I feel stupid for asking because Ive used SW for along time and have seen this message before but after doing so research on the Internet and my SW Bible I have yet to get the answer Im looking for. I opened an assembly that has an assembly in it and I had errors that told me to edit definition in the assembly that is referenced in this assembly. I opened that assembly and there are no errors. I checked all the parts and there are no error's.
SOLIDWORKS Forums
2 days ago
I have been a Solidworks user since 2001 and have not had to model a mechanism like this until now. I need to model a mechanism similar to the one shown in this video. (pretty cool motion)
SOLIDWORKS Forums
2 days ago
Utilizing Multibody parts I'm in the habit of creating certain parts as a single multi-body part rather than using assemblies. It ends up making things a lot easier.
SOLIDWORKS Forums
2 days ago
I can't find a mate that works to attach the straps. Start a 3D sketch and place points on the inner surface of the helmet and mate to the points. Where are your planes in the Helmet.
SOLIDWORKS Forums
2 days ago
I started working with the design table tool lately, I must say this saves me a lot of time as I often use multiple configurations parts to create multiple configurations assemblies . I couldn’t figure out how to insert sub assemblies and or parts in subassemblies feature dimensions in the main assembly design table , so I can work on 1 assembly to create multiple configurations from a simple excel sheet .
SOLIDWORKS Forums
3 days ago
Flex-Concentric... what?? Soooo...
SOLIDWORKS Forums
3 days ago
Can I use any fasteners in abs plastic or is there some special requirement like how fiberglass shouldn't have threads? I googled what kind of fasteners are for abs plastic. I didn't really get a clear answer.
SOLIDWORKS Forums
3 days ago
Measuring within assemblies I know I mentioned this a while ago but it is something that costs me a lot of time.
SOLIDWORKS Forums
3 days ago
Please watch this video, for a complete explanation of what is expected in this challenge:https://youtu.be/JZZ_Y_tryy8 Hello SOLIDWORKS Power-Users and welcome to the 11th WPUC!
SOLIDWORKS Forums
3 days ago
I'm having intermittent issues where I am prompted to save a read only-toolbox fastener. I have "Don't prompt to save read-only referenced documents (discard changes)" checked in System Options > External References. Has anyone experienced this behavior before?
SOLIDWORKS Forums
3 days ago
When I import a screw from the library I give "Failed to get writable document!" And shut down the program What should I do? Something happened with the program?
SOLIDWORKS Forums
4 days ago